1

I will try to explain my problem. I am trying that Switch 1 can give dhcp for pcs but i cannot, in Switch 0 I can give dhcp server in the pcs. sorry for my bad english

enter image description here ROUTER

    !
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
ip dhcp excluded-address 10.82.52.2 10.82.52.10
!
ip dhcp pool ISSINET
 network 10.82.52.0 255.255.255.0
 default-router 10.82.52.1
 dns-server 8.8.8.8
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15240O69
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.52
 encapsulation dot1Q 52
 ip address 10.82.52.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 5
 network 10.0.0.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Switch 0

Current configuration : 2353 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 52
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 52
 switchport mode trunk
!
interface FastEthernet0/5
 switchport access vlan 52
 switchport mode trunk
!
interface FastEthernet0/6
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/19
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 52
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 52
 switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan52
 ip address 10.82.52.1 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

Switch 1

Current configuration : 3115 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/3
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/4
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/5
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/6
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/7
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/8
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/9
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/10
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/11
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/12
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/13
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/14
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/15
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/16
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/17
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/18
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/19
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/20
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/21
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/22
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/23
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface FastEthernet0/24
 switchport access vlan 52
 switchport trunk allowed vlan 52
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan52
 ip address 10.82.52.1 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end
enter preformatted text here


Switch#show vlan brief

 VLAN Name                             Status    Ports
 ---- -------------------------------- --------- -------------------------------
 1    default                          active    Gig0/1, Gig0/2 52   int                              active 
                                                 Fa0/2, Fa0/3, Fa0/6, Fa0/7
                                                 Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                 Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                 Fa0/16, Fa0/17, Fa0/19, Fa0/20
                                                 Fa0/21, Fa0/22, Fa0/23, Fa0/24
 1002 fddi-default                     active     1003
 token-ring-default                    active     1004
 fddinet-default                       active     1005
 trnet-default                         active     
Switch#
  • 1
    You need to provide more information. We need to know the switch models and configurations. – Ron Maupin Aug 25 '18 at 2:18
  • Please, never use an image for text. Simply copy the text and paste it into your question, then use the Preformatted-text feature ({}). – Ron Maupin Aug 25 '18 at 2:28
  • Also, we need to full configurations for your switches and router. We cannot see other configurations that may have an affect. For example, we cannot see if you have defined VLAN 52 (not the SVI for the VLAN, but the VLAN definition). – Ron Maupin Aug 25 '18 at 2:37
  • Yes, I wrote Vlan 52 in both switches – Maximo Cozzetti Aug 25 '18 at 2:39
  • Show us the configurations. We cannot guess where you went wrong. Guessing and speculation are off-topic here. – Ron Maupin Aug 25 '18 at 2:40
2

You have some problems. First, you did not define the VLANs as you claimed in your comment. You did create the SVIs with the interface Vlan52 command, but that doesn't define the VLAN on the switch. You use the global Vlan 52 command to do that, and you can use sub-commands to name the VLAN if you would like.

I strongly suggest you use the description interface command to label which interface goes to which network device. so that it is easy to see the switch interfaces between the switches, the switch interface to the router. For special hosts, like the DHCP server, you should label that, too.

Also, on Switch 1, all your interfaces are configured as trunks, not access interfaces. Most end-devices (PCs, servers, printers, etc.) do not understand VLAN tags that trunks place on the ethernet frames, and they discard the frames as damaged. You need to configure the interfaces with the switchport mode access interface command.

Then, you have the router interface and both switch SVIs set with the same IPv4 address. The router interface and switch SVIs are like end-devices attached to the switches. They need separate IP addresses, or you will end up with duplicate addressing that will cause you all types of problems. You need unique addressing for every device on the network.

  • I defined, Show vlan brief – Maximo Cozzetti Aug 25 '18 at 3:05
  • No, you didn't. In the configuration it would have Vlan 52 right above the spanning-tree mode pvst. Not defining that can cause very subtle, hard to troubleshoot problems. – Ron Maupin Aug 25 '18 at 3:08
  • Thanks, I fixed what you wrote it and now I have Dhcp in pc of Switch 1 ;) – Maximo Cozzetti Aug 25 '18 at 3:32
  • other question, this topic what CCNA would be? – Maximo Cozzetti Aug 25 '18 at 3:35
  • I do not understand you other comment question. – Ron Maupin Aug 25 '18 at 3:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.