** Attempting to view IP address of a Non-Cisco device connected to the switchport. Already entered show mac address-table int gi0/35.

Got the mac, then tried the sho ip arp vlan 120 | include command, but get an error in the command. **

#sho ip arp vlan 120 Translating "vlan"...domain server ( ^ % Invalid input detected at '^' marker.

VER: C3560E Software (C3560E-UNIVERSALK9-M), Version 15.2(2)E4, RELEASE SOFTWARE (fc2)

I was just told to try adding a space between vlan & 120, still get an error, even though the command is in the list when I use "?"

the full command is:

#sho ip arp vlan 120 | include accc.8eac.13e7

Translating "vlan"...domain server (
% Invalid input detected at '^' marker.

I don't get it, this IS the correct syntax.

Any ideas? =======================================EDIT++++++++++++++++++++++++++++

#sho ip arp ?
  Async                Async interface
  Auto-Template        Auto-Template interface
  BVI                  Bridge-Group Virtual Interface
  CTunnel              CTunnel interface
  Dialer               Dialer interface
  FastEthernet         FastEthernet IEEE 802.3
  Filter               Filter interface
  Filtergroup          Filter Group interface
  GigabitEthernet      GigabitEthernet IEEE 802.3z
  GroupVI              Group Virtual interface
  H.H.H                48-bit hardware address of ARP entry
  Hostname or A.B.C.D  IP address or hostname of ARP entry
  Lex                  Lex interface
  Loopback             Loopback interface
  Lspvif               LSP virtual interface
  Null                 Null interface
  Port-channel         Ethernet Channel of interfaces
  Portgroup            Portgroup interface
  Pos-channel          POS Channel of interfaces
  TenGigabitEthernet   Ten Gigabit Ethernet
  Tunnel               Tunnel interface
  Vif                  PGM Multicast Host interface
  Virtual-Template     Virtual Template interface
  Virtual-TokenRing    Virtual TokenRing
  Vlan                 Catalyst Vlans
  fcpa                 Fiber Channel
  inspection           Status of ARP Inspection
  poll                 Show IP ARP host polling status
  summary              IP ARP table summary
  track                IP ARP Track table
  |                    Output modifiers

#sho ip arp Vlan ?
  <1-4094>  Vlan interface number
  |         Output modifiers

#sho ip arp Vlan 120 ?
% Unrecognized command
#sho ip arp Vlan 120

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/3, Gi1/4
78   switch name(omitted)             active    Gi0/1, Gi0/2, Gi0/3, Gi0/4
                                                Gi0/5, Gi0/6, Gi0/7, Gi0/8
                                                Gi0/9, Gi0/10, Gi0/11, Gi0/12
                                                Gi0/13, Gi0/14, Gi0/15, Gi0/16
                                                Gi0/17, Gi0/18, Gi0/19, Gi0/20
                                                Gi0/21, Gi0/22, Gi0/23, Gi0/24
                                                Gi0/25, Gi0/26, Gi0/27, Gi0/28
                                                Gi0/29, Gi0/30, Gi0/31, Gi0/32
                                                Gi0/34, Gi0/36, Gi0/37, Gi0/38
                                                Gi0/39, Gi0/40, Gi0/41, Gi0/42
                                                Gi0/43, Gi0/44
100  HVAC                             active
120  security_cameras                 active    Gi0/35, Gi0/45, Gi0/46,     Gi0/47
  • if you type "show ip arp ?" [enter] it should show you the available options.
    – JFL
    Mar 29, 2019 at 14:26
  • Are you sure there is a vlan 120?
    – Ron Trunk
    Mar 29, 2019 at 14:34
  • VLAN 120 is something different than SVI VLAN120 (the VLAN interface).
    – Teun Vink
    Mar 29, 2019 at 14:44
  • Is the VLAN 120 SVI defined and have a layer-3 address on it? ARP is for layer-3 interface, and if it is only a layer-2 interface then it will not use ARP. Layer-2 doesn't care about layer-3 (IP) addresses, so it doesn't use ARP to translate between layer-3 and layer-2.
    – Ron Maupin
    Mar 29, 2019 at 14:45
  • 2
    Edit your question to include the full switch configuration. We can then point out to you what may be wrong. Also, I think you are working on an X-Y Problem, so you should explain to use why you want to do this, and we may be able to tell you how to accomplish what you really want to do instead of how you want to do it.
    – Ron Maupin
    Mar 29, 2019 at 15:01

1 Answer 1


Most likely there is no Vlan interface on your switch. You can see, I have vlan10 and vlan11:

swTST01#show vlan | include VLAN
VLAN Name                             Status    Ports
10   LAN_VLAN                         active    
11   DSL_VLAN                         active  

But if i check the Vlan interfaces, i only have one for Vlan 10, but not for 11

swTST01#show ip interface brief | include Vlan
Vlan1                  unassigned      YES manual administratively down down    
Vlan10             YES NVRAM  up                    up

So if i wanna show my arp table, there is only one for the vlan that has an interface and an IP assigned to it:

swTST01#show ip arp vlan 10
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet              -   0008.326b.7fc1  ARPA   Vlan10
Internet            204   0000.0c07.ac01  ARPA   Vlan10
Internet            230   f40f.1b43.5728  ARPA   Vlan10
swTST01#show ip arp vlan 11
Translating "vlan"...domain server (
% Invalid input detected at '^' marker.

Arp works with IP addresses, so you can only see the arp cache on the device that has an IP on the specified Vlan. So if you wanna have a look at the arp table of this Vlan, you can do this on a client in this vlan, or on the device that acts as default gateway in this network, or you can configure a SVI on your switch like this:

swTST01#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
swTST01(config)#interface vlan 11
swTST01(config-if)#ip address dhcp

This only works if you have a DHCP server in the network of course. And you need to know what you are doing, because from this point on, your switch can most likely route traffic between interfaces that are directly connected. That could lead to some unwanted pathing for your traffic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.