1

I encountered a problem configuring a Cisco Catalyst 3560.

I have a trunk interface connected to a Linux server that operates services on different VLANs.

When I try to ping the router on 192.168.1.182 from a machine in VLAN 110, it works, but when I try for VLAN 98 to ping a host, even the Cisco can't ping itself.

When I looked at the network packets, the router sent ARP requests with a wrong tag and the wrong source address:

who has 192.168.3.2? Tell 192.168.1.182

The command show interfaces showed the VLAN interface connected sometimes (I can't manage to find out how it is decided to be set 98 up or down). In both cases it didn't work.

The only difference between those VLANs is VLAN 110 has others ports in access mode.

interface GigabitEthernet0/3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 98,110
 switchport mode trunk
 shutdown
!

[...]

interface GigabitEthernet0/11
 switchport access vlan 110
 switchport mode access

[...]

interface Vlan1
 no ip address
!
interface Vlan98
 ip address 192.168.3.1 255.255.255.252
!
interface Vlan110
 ip address 192.168.2.182 255.255.255.240
!
ip classless
ip http server
!
!
ip sla enable reaction-alerts
!
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end

Any idea?

4
  • 5
    I notice gi 0/3 is shutdown. Is that intended?
    – Ron Trunk
    Commented Jun 25, 2015 at 14:05
  • 3
    Also, nothing in that config suggest it's been setup for routing.
    – Ricky
    Commented Jun 25, 2015 at 21:00
  • 3
    You have something else odd in this description as well. Where does the 192.168.1.182 IP address in the ARP request come into the picture? Nowhere in your configuration is that IP range indicated. Maybe provide output of something like show ip interface brief and show ip route might help as well?
    – YLearn
    Commented Jun 26, 2015 at 18:58
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Commented Aug 11, 2017 at 18:34

2 Answers 2

1

G0/3 appears to be shut down. I suspect that SVI VLAN 110 is up because it exists on another port (G0/11) that is not shut down, and thus spanning-tree for VLAN 110 is up, while it is down for VLAN 98. You can confirm that by issuing the commands 'show spanning-tree vlan 110' and 'show spanning-tree vlan 98'. You'll probably get something like "Spanning tree instance(s) for vlan 98 does not exist."

1
  • Show span summary could be helpful here too.
    – cpt_fink
    Commented Dec 24, 2015 at 2:34
1

1: Port gi0/3 seems to be shut. You don´t be able to transmit traffic across him.

2: Do you have configured the two vlans with the two IPs in your Server?

3: You don´t be able to ping the vlanif 98 unless you assign an access port to that vlan and connect one pc with an IP on that network, or had configured on the right way the 2 vlan interfaces on your server.

The way you said that vlanif 98 connect sometimes, look that switch seems a flapping port assigned to that vlan. The only way vlanif will up, is that at least, one port must belong to that vlan

NEEDED: Can you put the configuration of your server??

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.