2

I am facing a very strange issue with regard to IS-IS Interface Metric / Cost calculation in Juniper MX. We have configured a reference bandwidth of 1000G on all routers.This by definition means an ae interface (with 2 x 10G member Links) would yield a cost of 50G (1000G/20G = 50). We can see this using command 'show isis interface' on Junos.

However in my case , we have two routers that are directly connected using Bundle Link (AE Link) that has 2 x 10G member Links. IS-IS is running between them. Now each router should have interface metric of 50. But from CLI we see that R1 has interface metric of 33 ! while R2 has interface metric of 50 (which is correct). So How R1 is saying interface metric is 33 when it has only 2 x 10G member links. (Cost should be 50 while Junos is saying a metric of 33).

Junos on R1 is 13.3R7-S3.1 while on R2 it is 15.1R6-S5. Both are MX960 series routers.

Many Thanks ... I now share CLI output to support my query :-

<------------------------------R2------------------------------------------->

R2> show lacp interfaces ae16 
Aggregated interface: ae16
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-8/3/2       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-8/3/2     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-8/0/0       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-8/0/0     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State 
      xe-8/3/2                  Current   Fast periodic Collecting distributing
      xe-8/0/0                  Current   Fast periodic Collecting distributing


R2> show configuration interfaces ae16 
apply-groups [ xge-if-parameters ubfd-ae ];
description Connected to R1;
aggregated-ether-options {
    bfd-liveness-detection {
        neighbor 192.168.0.38;
        local-address 192.168.0.13;
    }
    lacp {
        active;
        periodic fast;
    }
}
unit 3 {
    apply-groups core-ifl-parameters;
    vlan-id 3;
    family inet {
        address 10.10.20.2/30;
    }
    family mpls;
}


R2> show configuration protocols isis interface ae16.3 
apply-groups isis-ifl-parameters-wo-bfd;
ldp-synchronization;


R2> show configuration protocols isis                     
inactive: traceoptions {
    file isis-log;
    flag state;
}
reference-bandwidth 1000g;
lsp-lifetime 65535;
level 1 disable;
level 2 {
    authentication-key ""; ## SECRET-DATA
    authentication-type md5;
    wide-metrics-only;
}


interface ae27.3 {
    apply-groups isis-ifl-parameters-wo-bfd;
    ldp-synchronization;
}
interface ae29.3 {
    apply-groups isis-ifl-parameters;
    ldp-synchronization;
}
interface lo0.0;

R2> show isis interface ae16.3 
IS-IS interface database:
Interface             L CirID Level 1 DR        Level 2 DR        L1/L2 Metric
ae16.3                2   0x1 Disabled          Point to Point         50/50

<------------------------------R1------------------------------------------->

R1> show lacp interfaces ae16 
Aggregated interface: ae16
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/2/9       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/2/9     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-8/0/6       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-8/0/6     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State 
      xe-0/2/9                  Current   Fast periodic Collecting distributing
      xe-8/0/6                  Current   Fast periodic Collecting distributing


R1> show configuration interfaces ae16 
apply-groups [ xge-if-parameters ubfd-ae ];
description Connected to R2;
aggregated-ether-options {
    bfd-liveness-detection {
        neighbor 192.168.0.13;
        local-address 192.168.0.38;
    }
    link-speed 10g;
    lacp {
        active;
        periodic fast;
    }
}
unit 3 {
    apply-groups core-ifl-parameters;
    vlan-id 3;
    family inet {
        address 10.10.20.1/30;
    }
    family iso;
}


R1> show configuration interfaces ae16.3 
apply-groups core-ifl-parameters;
vlan-id 3;
family inet {
    address 10.10.20.1/30;
}
family iso;


R1> show configuration protocols isis 
reference-bandwidth 1000g;
lsp-lifetime 65535;
spf-options {
    delay 50;
    holddown 5000;
    rapid-runs 3;
}
level 1 disable;
level 2 {
    authentication-key ""; ## SECRET-DATA
    authentication-type md5;
    wide-metrics-only;
}

interface ae16.3 {
    apply-groups isis-ifl-parameters-wo-bfd;
    ldp-synchronization;
}

}
interface ae45.3 {
    apply-groups isis-ifl-parameters;
    ldp-synchronization;
    level 2 metric 33;
}
interface ae46.3 {
    apply-groups isis-ifl-parameters;
    ldp-synchronization;
    level 2 metric 33;
}
interface lo0.0 {
    passive;
}


R1> show isis interface ae16.3 
IS-IS interface database:
Interface             L CirID Level 1 DR        Level 2 DR        L1/L2 Metric
ae16.3                2   0x1 Disabled          Point to Point         33/33

R1> show route 192.168.0.13 

inet.0: 38694 destinations, 113966 routes (38470 active, 1 holddown, 226 hidden)
+ = Active Route, - = Last Active, * = Both

192.168.0.13/32    *[IS-IS/18] 1d 06:58:47, metric 33
                    > to 10.10.20.2 via ae16.3
4
  • Cost/metric for IS-IS isn't usually calculated automatically. And you did configure the interface metrics to 33...
    – Zac67
    Commented Mar 17, 2019 at 20:10
  • @Zac67. Thanks for the reply. Yes you are right. When we didnt configure the interface metric under isis config hierarchy , then router uses the formula (1000G/20G) to calculate the cost. We configure the interface cost but its not the interface in question. The interface in question is ae16.3. You can see from R1 and R2 that no metric has been defined under ae16.3
    – Nabeel
    Commented Mar 17, 2019 at 20:13
  • @JordanHead. Can you please just go through this. I suspect this is a bug. Thanks
    – Nabeel
    Commented Mar 21, 2019 at 18:19
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Commented Nov 19, 2022 at 23:56

1 Answer 1

0

Check link Speed configuration on ae16 in R1

1
  • 3
    Welcome to Network Engineering! We hope you will continue to be a contributing member, Please consider expanding your answer to explain what a correct configuration might be, That will help future readers with similar problems.
    – Ron Trunk
    Commented Sep 7, 2022 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.