0

I have this rather basic setup with 3 routers running BGP, each has Loopback int configured. Is there an extra step required for R2 to ping R4 Loopback interface despite it's being advertised?

enter image description here

R2#sh run | s bgp
router bgp 65001
 bgp log-neighbor-changes
 neighbor 11.0.0.1 remote-as 65001
 neighbor 22.0.0.2 remote-as 65002
 !
 address-family ipv4
  network 172.17.0.1 mask 255.255.255.255
  neighbor 11.0.0.1 activate
  neighbor 22.0.0.2 activate
 exit-address-family

R3#sh run | s bgp
router bgp 65002
 bgp log-neighbor-changes
 neighbor 22.0.0.1 remote-as 65001
 neighbor 33.0.0.2 remote-as 65002
 !
 address-family ipv4
  neighbor 22.0.0.1 activate
  neighbor 33.0.0.2 activate
 exit-address-family

R4#sh run | s bgp
router bgp 65002
 bgp log-neighbor-changes
 neighbor 33.0.0.1 remote-as 65002
 !
 address-family ipv4
  network 172.19.0.1 mask 255.255.255.255
  neighbor 33.0.0.1 activate
 exit-address-family



Gateway of last resort is not set

      11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        11.0.0.0/30 is directly connected, Ethernet0/0
L        11.0.0.2/32 is directly connected, Ethernet0/0
      22.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        22.0.0.0/30 is directly connected, Ethernet0/1
L        22.0.0.1/32 is directly connected, Ethernet0/1
      172.16.0.0/32 is subnetted, 1 subnets
B        172.16.0.1 [200/0] via 11.0.0.1, 00:16:57
      172.17.0.0/32 is subnetted, 1 subnets
C        172.17.0.1 is directly connected, Loopback1
      172.19.0.0/32 is subnetted, 1 subnets
B        172.19.0.1 [20/0] via 22.0.0.2, 01:13:24

R2#sh bgp ipv4 unicast
BGP table version is 16, local router ID is 172.17.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 172.16.0.1/32    11.0.0.1                 0    100      0 i
 *>  172.17.0.1/32    0.0.0.0                  0         32768 i
 *>  172.19.0.1/32    22.0.0.2                               0 65002 i
9
  • Can you post full sanitized configs for all of the routers?
    – Jesse P.
    Commented Apr 8, 2021 at 12:19
  • 1
    You are not advertising any networks in BGP.
    – Ron Maupin
    Commented Apr 8, 2021 at 12:24
  • 3
    @JesseP., there are no network statements or redistribution commands under BGP to actually advertise any networks.
    – Ron Maupin
    Commented Apr 8, 2021 at 12:42
  • 1
    thanks for pointing me in the right direction, I have added network 22.0.0.0 mask 255.255.255.252 network 33.0.0.0 mask 255.255.255.252 on R3 and I'm able to ping remote nets, thanks
    – imperato
    Commented Apr 9, 2021 at 9:38
  • 1
    @imperato As a side note, you really shouldn't be using public addresses for your internal BGP peerings because now you e effectively blackholed traffic to whoever those blocks belong to, should you ever need to access them publicly.
    – Jesse P.
    Commented Apr 9, 2021 at 12:26

1 Answer 1

0

thanks for pointing me in the right direction, I have added network 22.0.0.0 mask 255.255.255.252 network 33.0.0.0 mask 255.255.255.252 on R3 and I'm able to ping remote nets, thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.