4

I need some help. I am new to using Cisco routers (as far as setting them up my self), so forgive me if this is something simple that I am over looking or not understanding.

I have a cable internet from cox. They gave the the IP address below:

IP: 98.191.**.147 
DG: 98.191.**.129
SNM 255.255.255.224

The IP address is the IP address that will connect the router to the ISP modem. On the LAN side, I have the following:

IP address 10.0.4.1
DG 10.0.4.254
SNM 255.255.255.0

What I need to do is take 10.0.4 network and tell it the Internet is at the 98.191.**.147 network address, and connect to the Internet that way. I have been watching some YouTube videos on how to do this, but there is something I'm missing, and I cant figure it out.

Here is what i have thus far :

I get no internet connection on the 10 dot network.

Router#show ip interface brief
 Interface IP-Address OK? Method Status Protocol
 FastEthernet0/0 10.0.4.1 YES manual up up
 FastEthernet0/1 98.191.**.147 YES manual up up
 Vlan1 unassigned YES unset administratively down down
 Router#

here is the rest...

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 98.191.**.147 255.255.255.224
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 98.191.**.147 255.255.255.224
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!

end

Updated Changes

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.4.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 98.191.**.147 255.255.255.224
 ip nat outside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
access-list 1 permit 10.0.4.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!

end

startup config

!

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.4.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 ip address 98.191.**.147 255.255.255.224
 ip nat outside
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
access-list 1 permit 10.0.4.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

New Update as of 6/17/16

Router#
Router#show running
Router#show running-config
Building configuration...

Current configuration : 753 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.4.254 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 98.191.**.138 255.255.255.224
 ip nat outside
 duplex auto
 speed auto
!
ip classless
!
ip http server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.0.4.0 0.0.0.255
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router#

i can ping 98.191.**.147 and get a 100% success but i try to ping 10.0.4.55 (the other pc) i get a 100% fail.

In other words i get single directional traffic

4
  • You need to configure Port Address Translation (PAT). Something like cisco.com/c/en/us/support/docs/…. Commented Jun 15, 2016 at 17:03
  • It might seem obvious at this point, but I'm curious about the output of show ip route. Commented Jun 15, 2016 at 23:23
  • Just to follow up on my comments below, Ron has edited his answer and I agree with him that basically you are done. The fact that you can only ping one-way is expected because of how NAT works. You won't need or want nodes on the Internet to be able to ping back into your network anyway, right? Note that if you can ping from inside to outside, technically that is two-way traffic. Echo-request goes out from the network, and then an echo-reply comes back in. Same way accessing a web site works (just using TCP instead of ICMP). Commented Jun 17, 2016 at 16:01
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Commented Jan 7, 2021 at 1:12

1 Answer 1

4

Your LAN addressing is private addressing, and you cannot route that to the Internet. You will need to use NAT. You will set up the WAN interface as the outside interface, and the LAN interface as the inside interface. You need to then define the translation. Usually, you want the source IP address of traffic from the inside (private address) to be translated to your outside address (public address).

Example:

interface FastEthernet0/0
 ip address 10.0.4.1 255.255.255.0
 duplex auto
 speed auto
 ip nat inside
!
interface FastEthernet0/1
 ip address 98.191.**.147 255.255.255.224
 duplex auto
 speed auto
 ip nat outside
!
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.0.4.0 0.0.0.255
!

This will translate the source address of any traffic in the 10.0.4.0/24 network to be your WAN address of 98.191.**.147. This way, any reply traffic will come to your router and be translated back to the correct address on your LAN.

Also, you will need a default route:

ip route 0.0.0.0 0.0.0.0 98.191.**.149

Edit for you update:

Using NAT the way you have, you will get uni-directional origination for traffic. The outside cannot originate traffic to the inside. That is because the NAT table is built as traffic comes from the inside to the outside, but the table entries don't exist if traffic is originated from the outside. The router has no idea where to send, on the inside, traffic to its outside interface. Typically, this is done with private addressing on the inside, and public addressing on the outside, and the private addresses can't be use on the public network, anyway.

Likely, your ping from the outside is reaching the inside host, but when the inside host replies, the reply has its source address translated to the router WAN address, so the outside host doesn't see a reply from the address it is trying to ping. The ping then fails, even though it is working.

28
  • I have made changes and posted the changes above. Its still not working yet it keeps failing
    – Kelly
    Commented Jun 15, 2016 at 16:20
  • 1
    Yes, i have one computer with 10.0.4.5 as the ip address and snm of 255.255.255.0 and dfg of 10.0.4.1. and for the other computer i have 98.191.**.149 for the ip address and 255.255.255.224 and 98.191.**.129 as dfg
    – Kelly
    Commented Jun 15, 2016 at 16:54
  • 1
    I can't tell you about packet tracer. That is a Cisco learning tool, but what I gave you as an example should work. Can you ping the router's WAN interface (98.191.**.147) from from both PCs?
    – Ron Maupin
    Commented Jun 15, 2016 at 17:12
  • 1
    @Kelly First, can each PC ping their own default gateways? Second, have you made sure there are no software firewalls enabled on either PC? Third, can the router ping both PCs? If the router can't ping a PC, then the other PC definitely can't. If the router can ping and the other PC can't, then the problem is with the router config. Commented Jun 15, 2016 at 23:21
  • 1
    @RonMaupin thank you for the update... so what would i need to change?
    – Kelly
    Commented Jun 17, 2016 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.