1

enter image description here

We have above scenario where currently we have only single link with ISP ROUTER1 but soon we are planning to have second link on same BGP router but ISP side it will comes from ISP ROUTER2.

I heard its recommended to configure BGP with loopback source but i don't know how does that fit in DUAL router scenario. This is what we have currently configured in my router.

router bgp 30000
 bgp log-neighbor-changes
 network xx.xx.xx.xx mask 255.255.255.0
 timers bgp 10 30
 redistribute static route-map RTBH
 neighbor 66.xx.xx.65 remote-as 10000
 neighbor 66.xx.xx.65 description ***** ISP-ROUTER1 *****
 neighbor 66.xx.xx.65 send-community
 neighbor 66.xx.xx.65 weight 100
  • It's not clear what your question is. What do you want to accomplish? One like primary, and the second a backup link? Do you want both links to be active? ave you talked to your ISP about what you want to do? – Ron Trunk Aug 9 '16 at 2:12
4

You want to configure iBGP with loopback sources because you will probably have multiple ways for traffic to get into the router, and the loopback never goes down. That means that the router can keep sending and receiving updates. Also, iBGP requires a full mesh, and an interface or link going down could break that unless you have it source from a loopback.

With eBGP it is a little different. You normally want to configure eBGP on the connecting interface so that BGP does notice when the link goes down. Also, eBGP can't use a different interface unless you configure ebgp multihop. Your ISP may not even want you to do that because they don't want BGP updates flowing around inside its network to get to the other router. Likely, your ISP is not configuring that way, and if the interface is down on the ISP router, you couldn't get to it for updates, anyway.

|improve this answer|||||
  • we have eBGP peer, (ISP won't allow iBGP peering), In that case we can't use lookback source right? – Satish Aug 9 '16 at 2:28
  • You shouldn't unless you have a compelling reason to do so. Normally, you would only do that if both sides of the eBGP connection belonged to you, not between you and another company. – Ron Maupin Aug 9 '16 at 2:30
0

Method of peering using a loopback interface is useful since it will not bring down the BGP session when there are multiple paths between the BGP peers, which would otherwise result in tearing down the BGP session if the physical interface used for establishing the session goes down. In addition to that, it also allows the routers running BGP with multiple links between them to load balance over the available paths.

http://datagram.network/

|improve this answer|||||
  • agreed, but how does that work in my scenario where i have dual link terminated on two different router? – Satish Aug 9 '16 at 12:58
  • The use of a loopback interface to define neighbors is common with iBGP, but is not common with eBGP. Normally, you use the loopback interface to make sure that the IP address of the neighbor stays up and is independent of hardware that functions properly. In the case of eBGP, peer routers frequently have direct connection, and loopback does not apply. I would get touch with your ISP to get more details. As well is worthy to use command maximum-paths to enable load sharing. – Datagram.Network Aug 9 '16 at 13:26
0

Sample configuration would be:

Create loopback

interface Loopback0
ip address 1.1.1.1 255.255.255.255

Add update-source statment:

router bgp 30000
neighbor 66.xx.xx.65 update-source Loopback0
|improve this answer|||||
  • This works fine for iBGP, but it will not work with eBGP unless you use ebgp multihop. You will never get a peer connection by changing the update source on eBGP without it. – Ron Maupin Aug 9 '16 at 13:26
  • That's correct as I stated in comment below usually is used for iBGP peers isn't common for eBGP. – Datagram.Network Aug 9 '16 at 13:29
  • oh! so you mean i should drop that source loopback idea for eBGP right, if its not practical then i don't want to mess with it – Satish Aug 9 '16 at 14:50
  • ebgp multihop is out of question because we have directly connected link – Satish Aug 9 '16 at 14:56
  • ebgp multihop could be configured as well on directly connected links. This tell BGP how many hops away is peering router default is 1. As well while multihop is in use there need to be valid route to host (default route won't work) – Datagram.Network Aug 9 '16 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.