1

Here is my topology:

topology picture

I'm trying to get a DHCP IP address for a Windows XP client, but when I do the ipconfig /renew command, it said, can not use the rpc server and failed to get an ip address from dhcp server.

Please check my topology and configurations:

R

 Router#sh run
    Building configuration...

    Current configuration : 1091 bytes
    !
    ! Last configuration change at 14:17:26 UTC Fri Oct 28 2016
    !
    version 15.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    aqm-register-fnf
    !
    !
    no aaa new-model
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !


    !
    ip dhcp excluded-address 1.1.1.254
    ip dhcp excluded-address 1.1.1.1 1.1.1.10
    !
    ip dhcp pool A
    network 1.1.1.0 255.255.255.0
    default-router 1.1.1.254
    dns-server 168.126.63.1
    lease 0 8
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy

    !
    interface Ethernet0/0
    ip address 1.1.2.2 255.255.255.0
    !
    interface Ethernet0/1
     no ip address
    shutdown
    !
    interface Ethernet0/2
    no ip address
    shutdown
    !
    interface Ethernet0/3
    no ip address
    shutdown
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server

    control-plane

    line con 0
    logging synchronous
    line aux 0
    line vty 0 4
     login
    transport input none
    !
    !
    end

R1

    Router#sh run
Building configuration...

Current configuration : 2327 bytes
!
! Last configuration change at 12:59:47 UTC Fri Oct 28 2016
!
version 15.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 1.1.1.254 255.255.255.0
 ip helper-address 1.1.2.2
!
interface Ethernet0/1
 ip address 1.1.2.1 255.255.255.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Ethernet2/0
 no ip address
 shutdown
!
interface Ethernet2/1
 no ip address
 shutdown
!
interface Ethernet2/2
 no ip address
 shutdown
!
interface Ethernet2/3
 no ip address
 shutdown
!
interface Ethernet3/0
 no ip address
 shutdown
!
interface Ethernet3/1
 no ip address
 shutdown
!
interface Ethernet3/2
 no ip address
 shutdown
!
interface Ethernet3/3
 no ip address
 shutdown
!
interface Ethernet4/0
 no ip address
 shutdown
!
interface Ethernet4/1
 no ip address
 shutdown
!
interface Ethernet4/2
 no ip address
 shutdown
!
interface Ethernet4/3
 no ip address
 shutdown
!
interface Ethernet5/0
 no ip address
 shutdown
!
interface Ethernet5/1
 no ip address
 shutdown
!
interface Ethernet5/2
 no ip address
 shutdown
!
interface Ethernet5/3
 no ip address
 shutdown
!
interface Ethernet6/0
 no ip address
 shutdown
!
interface Ethernet6/1
 no ip address
 shutdown
!
interface Ethernet6/2
 no ip address
 shutdown
!
interface Ethernet6/3
 no ip address
 shutdown
!
interface Ethernet7/0
 no ip address
 shutdown
!
interface Ethernet7/1
 no ip address
 shutdown
!
interface Ethernet7/2
 no ip address
 shutdown
!
interface Ethernet7/3
 no ip address
 shutdown
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input none
!
!
end

Another question:

I put the DHCP server's default-router address as 1.1.1.254, but when do we need this default router address and dns-server address?

5
  • You have not included the full configurations in your question. Please edit your question to include the configurations. You can use the Preformatted Text feature.
    – Ron Maupin
    Commented Oct 28, 2016 at 14:48
  • Hi Ron, I think I put all my configuration for R1 and R. I'm pretty new to network area. So I might miss something some configuration. can you tell me which configuration you need ?
    – Mike Kim
    Commented Oct 28, 2016 at 14:51
  • Please include the full configs for both routers. Do you have a route on R2 for 1.1.1.0/24?
    – Ron Trunk
    Commented Oct 28, 2016 at 14:52
  • You are going to need a lot more configuration than what is in the image for this to work. Just do a show running-configuration on each device, copy the text, paste it into your question, highlight it, and click the Preformatted Text button ({}).
    – Ron Maupin
    Commented Oct 28, 2016 at 14:53
  • ok hold on I will put it
    – Mike Kim
    Commented Oct 28, 2016 at 14:54

1 Answer 1

1

From what I can see in your configuration of R, it doesn't have a route to the 1.1.1.0/24 network.

You really shouldn't use the default-router command, but if you do, it needs to be a network that R knows about. That would be the directly attached network, and the default-router should be 1.1.2.1.

A better option would be to either use a static route to the 1.1.1.0/24 network:

ip route 1.1.1.0 255.255.255.0 1.1.2.1

or put in a default route:

ip route 0.0.0.0 0.0.0.0 1.1.2.1

or run a routing protocol between the two routers.

9
  • ok i will try it
    – Mike Kim
    Commented Oct 28, 2016 at 15:20
  • The ip helper-address command will get the DHCP request to the R, but R doesn't know where to send the reply. That command doesn't actually do any routing. A router needs to know where to send packets. It either learns that from directly connected networks, static routes, or routing protocols. R has no way to know where network 1.1.1.0/24 is, so it doesn't even know where the configured default-router is to send packets to it.
    – Ron Maupin
    Commented Oct 28, 2016 at 15:23
  • I think default-router is referring to the DHCP option used to tell the client what its default gateway is, not an IOS command to define a route. So default-router 1.1.1.254 seems ok? - Having said that, indeed the problem seems to be that R does not have a route to 1.1.1.0/24.
    – hertitu
    Commented Oct 28, 2016 at 15:25
  • In my answer, I gave you two better options to the default router command. You normally don't use that command on routers. The preferred method is to use a routing protocol. A default route will send packets to the next hop router, even if the router doesn't have a route to the destination. Individual static routes will work if the network is small, but it doesn't scale.
    – Ron Maupin
    Commented Oct 28, 2016 at 15:36
  • Ok Ron, seems like I can ping to the R router from kali. but I'm still having a problem to get IP address in window. when I put ipconfig /renew in window. I get a message as " An error occurred while renewing interface local area network : RPC server can not use"
    – Mike Kim
    Commented Oct 28, 2016 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.