1

As the question says,

Is it possible to do interVLAN routing on a router on a stick configuration on a Cisco ISR C891F with tagged interfaces?

Let's I have 2 VLAN.

interface vlan 1
  ip address 192.168.0.1
interface vlan 2
  ip address 192.168.1.1

And also I have one interface tagged for each VLAN.

interface GigabitEthernet 1
  switchport access vlan 1
interface GigabitEthernet 2
  switchport access vlan 2

Is it possible to make both VLAN communicate for devices connected through those interfaces?

This router doesn't supports private-vlan and finally remember that there is not a switch, only this router.

Thank you!

0

First, you are confused about tagging. Access interfaces do not tag frames. Trunk interfaces tag frames. The two interface you show are not tagging frames unless you have specifically configured them to be trunk interfaces. Because trunks carry frames for multiple VLANs, you tag the frames so that the other end of the trunk (usually another switch or router) knows which frames belong to which VLANs. Most hosts don't understand VLAN tags, and there is no reason to tag frames if there is traffic for only one VLAN on an interface, so access interfaces do not tag frames.

You really are not doing router-on-a-stick (that would be using a single physical router interface with subinterfaces, not switch interfaces). Since you have created SVIs on a router, the default is to route between the networks, so you are routing between the VLANs unless you have created some configuration, e.g. ACLs, to block it.

2
  • Oh, thank you. Now I understand. So if I made my self clear, in this case the "switchpot access vlan" is to assume that the incoming traffic goes to that VLAN, and then it can still be routed and communicate to other VLANs by default. Am I correct? – user34559 May 25 '17 at 4:47
  • 1
    Yes. By default, your router will route traffic between the different networks. Your hosts on the various VLANs would use the addresses you have assigned to the SVIs as their gateways, then a host will send traffic destined to a different network (VLAN) to the router SVI for its VLAN, and the router will automatically route the traffic to the correct network. – Ron Maupin May 25 '17 at 13:26
0

Configuration mentioned above seems to be configured in router . If it is configured in router then there is no inter vlan routing is available .

Two network are connected through router two interfàce . Two Vlans subnet networks will communicate by default as per your communication . No inter -Vlan routing is required to ensure communication between both Vlans .

Traffic from Vlan1 reaches to router and it's check route for destination ip address which is Vlan 2 as it is directly connected network . It checks ARP table in router and get mac -address of destination ip address and with reference to mac - address packet is forwarded to destination which is Vlan 2 host.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy