0

I made a topology which has 2 separate networks connected to a router, each network has 1 switch and 2 pc's. I took a screenshot of the topology: https://i.gyazo.com/f99231fc75a41faa3ccd0315859fd84f.png

Gig0/0/0 Network can ping the router while the Gig0/1/0 network can't, what is the reasoning? And what could i possibly do to make both of the networks ping each other?

hostname Router
!
!
no ip cef
no ip ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
switch mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/1
switch mode access
!
interface GigabitEthernet0/1/2
switch mode access
!
interface GigabitEthernet0/1/3
switch mode access
!
interface Vlan1
no ip address
shutdown
!
router rip
! 
ip default gateway 192.168.2.254
ip classless
!
ip flow-export version 0
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
3
  • 2
    Please edit your question to include the configuration of your router. Use the preformatted text option { }.
    – Ron Trunk
    Commented Jul 1, 2020 at 13:06
  • The reasoning if you made a mistake somewhere but since you didn't provide the configuration we cannot tell where.
    – JFL
    Commented Jul 1, 2020 at 13:14
  • I will do that now, thank you for notifying me.
    – Muath
    Commented Jul 1, 2020 at 13:28

2 Answers 2

0

Interface Gi 0/1/0 is a switchport (layer 2) interface, not layer 3.
You can either:

Change the interface to layer 3 and assign an IP address (on a new subnet).

interface gi 0/1/0
no switchport
ip address 1.2.3.4  255.255.255.0
no shut

Or, create a SVI (layer 3 interface for VLAN 1, since that's the VLAN Gi 0/1/0 is assigned to by default.

interface vlan 1
ip address 1.2.3.4 255.255.255.0
no shut
0
0

Gi0/1/0 is a switchport and it is not define any vlans which means it is using the default vlan.

You need to no shut the vlan1 and define the ip address on vlan1.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.