0

I'm working in a network on packet tracer, when I'm sending ICMP requests from VLAN 20 (yellow field) to VLAN 10 (turqoise field) the packets get stuck at the switch where it is connected to.

Case 2: I'm trying to achieve the L2 and the L3 switch to function as a router with the goal to make inter-vlan routing possible.

Did I overlook something to correctly configure inter-vlan routing in this setup?

Networks used here:

  • VLAN 10: 192.168.10.1/24 Server room
  • VLAN 20: 192.168.20.1/24 Administration

enter image description here

My config from my L2 switch:

Building configuration...

Current configuration : 1773 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
ip dhcp pool 20
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.1
 dns-server 8.8.8.8
!
!
!
no spanning-tree vlan 20
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
 switchport mode trunk
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
 switchport mode trunk
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
 ip address 192.168.30.1 255.255.255.0
!
interface Vlan40
 ip address 192.168.40.1 255.255.255.0
!
ip default-gateway 192.168.20.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Config from the multilayer switch:

Building configuration...

Current configuration : 1789 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
ip dhcp pool 20
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.1
 dns-server 8.8.8.8
ip dhcp pool 30
 network 192.168.30.0 255.255.255.0
 default-router 192.168.30.1
 dns-server 8.8.8.8
ip dhcp pool 40
 network 192.168.40.0 255.255.255.0
 default-router 192.168.40.1
 dns-server 8.8.8.8
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no spanning-tree vlan 10
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/22
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
 no switchport
 no ip address
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end
1
  • Type show spanning-tree vlan 10 and show spanning-tree vlan 20 on both devices.
    – Ron Trunk
    Commented Jul 17, 2023 at 18:20

2 Answers 2

2

It's almost impossible to tell without information such as VLAN and spanning tree status information on each switch, etc. but I would guess from a quick glance that you have problems between the switches due to the VLANs not being defined on the switch running version 12.2(37)SE1

You should set the hostname on the switches to make things clear.

You address the first switch as Layer 2 but it is clearly a layer 3 switch due to having SVI (VLAN interfaces) and DHCP functionality.

You also have the same network defined for DHCP function on both switches. Also the 3rd switch configuration is not shown at all so we can't really guess on what might be wrong there.

Start from the top down and check all of your configuration again to make sure:

VLANs are defined the same on all switches. VLAN interface IP addresses do not overlap. DHCP configuration is consistent.

Verify interface and trunk status on all switches. Verify spanning-tree status for each VLAN on all switches. Check log output when enabling interfaces between switches for errors relating to trunk configuration or VLAN errors and spanning-tree errors.

2
  1. The VLANs need to be created on the L3 switch.
  2. The gateway IP addresses must be configured on the L3 switch, on each VLAN interface/SVI.
  3. IP addresses on an L2 switch are for management only - usually you only configure a single address in the management VLAN.
  4. You should use friendly port names (kudos FrameHowitzer) for reference and to avoid misconfiguration.
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.