3

The company I work for has multiple remote "IoT" style sites connected back to the datacenter via a Cisco 819 cellular router. We are in the process of upgrading these to the newer Cisco IR809 routers since the 819 is EOL and is becoming increasingly unreliable. The vast majority (>90%) of these sites are a stub network with a singular host connected directly to the router. All of these upgrades are going very smoothly.

The subnet in question here has 2 hosts (camera and sensor) connected back to the datacenter via a GRE tunnel. The stub network has a subnet with a /29 mask. The existing configuration leverages the flexibility of the 819's switchports and creates a routed SVI connected to a VLAN for the 2 devices. I'd like to be able to replicate this configuration but unfortunately the 809's 2 routed ports are unable to be utilized as switchports.

Given this is a remote data collection site (~50 miles from the datacenter) with nearly 0 likelihood of additional hosts, I'd like to avoid also installing a switch if possible (2 points of failure, additional expense, more maintenance, etc.) I would also prefer to utilize the same equipment as the other remote stub networks which all only have a singular host connected via an IR809.

Is such a configuration possible?

Existing config snippet on 819:

interface vlan 49
ip address 10.x.x.49 255.255.255.248

interface FastEthernet 1
switchport access vlan 49
no ip address

interface FastEthernet 3
switchport access vlan 49
no ip address

Topology Diagram

2
  • Have you looked at IRB? I'm not sure about that particular router, but most Cisco routers can be configured to bridge the router interfaces and use a virtual router interface as the layer-3 interface. This is not the same thing as the switch commands for a built-in switch module that you had before (a BVI, not an SVI).
    – Ron Maupin
    Commented Aug 26, 2019 at 14:40
  • Or just add a switch. (the 819 had one built in)
    – Ricky
    Commented Aug 26, 2019 at 15:44

1 Answer 1

4

If your router can use IRB (Integrated Routing and Bridging), you could set up something like this:

bridge irb ! <- *** Enable IRB ***
!
interface FastEthernet0/0
 no ip address
 bridge-group 1 ! <- *** Set the bridge group used ***

interface FastEthernet0/1
 no ip address
 bridge-group 1 ! <- *** Set the bridge group used ***
!
interface BVI1 ! <- *** The virtual router interface you create for the bridge group ***
 ip address 10.x.x.49 255.255.255.248
!
bridge 1 protocol ieee ! <- *** Set the bridge protocol used ***
!
bridge 1 route ip ! <- *** Enable routing to the bridge ***
!
1
  • Thank you! The configuration worked perfectly! Commented Aug 27, 2019 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.