0

I need to do a labwork on Packet Tracer and everything's good but I can't properly setup static routes.

There is my problem :

screen

So those networks can communicate but Room 3 can't ping a PC in Room 2.

My static routes of router 2 and 3 are fine for letting communicate room 3 & 4 and room 1 & 2.

enter image description here

But I don't know how to setup the other routes...

Here is the file.

https://we.tl/t-saeCr3KnlO

Please help me I'm so stucked..

[Edit]

Here is my configuration : enter image description here enter image description here

Routers conf :

2 :

enter image description here

Full config :

Router#show running-config
Building configuration...

Current configuration : 961 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX1017WZKG-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.0.3.1 255.0.0.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
!
ip classless
ip route 192.168.2.0 255.255.255.0 192.168.1.2 
ip route 192.168.1.0 255.255.255.0 192.168.2.2 
ip route 192.168.5.0 255.255.255.0 10.0.2.1 
ip route 192.168.2.0 255.255.255.0 10.0.2.1 
ip route 192.168.2.1 255.255.255.255 10.0.2.1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

3 :

enter image description here

Full config :

Router#show running-config
Building configuration...

Current configuration : 1341 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX101779TZ-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.5.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.4.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 10.0.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
!
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.4.2 
ip route 192.168.3.0 255.255.255.0 192.168.5.2 
ip route 192.168.4.0 255.255.255.0 192.168.3.2 
ip route 192.168.4.0 255.255.255.0 192.168.5.2 
ip route 192.168.5.0 255.255.255.0 192.168.3.2 
ip route 192.168.5.0 255.255.255.0 192.168.4.2 
ip route 192.168.2.0 255.255.255.0 10.0.3.1 
ip route 192.168.1.0 255.255.255.0 10.0.3.1 
ip route 192.168.5.0 255.255.255.0 10.0.3.1 
ip route 192.168.5.0 255.255.255.0 192.168.2.2 
ip route 192.168.5.2 255.255.255.255 10.0.3.1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
6
  • 3
    Please post your configurations here, not everyone is using Packet Tracer and many people aren't comfortable with just downloading some files from an unknown source
    – Teun Vink
    Commented Oct 5, 2023 at 10:58
  • 1
    Do you have routes to the other direction? (ping waits for its pong - echo request waits for an echo reply)
    – manish ma
    Commented Oct 5, 2023 at 11:10
  • @TeunVink I posted it, sorry I wasn't aware of it
    – akira
    Commented Oct 5, 2023 at 12:48
  • @manishma prolly yes I tried every routes in my opinion...
    – akira
    Commented Oct 5, 2023 at 12:48
  • Please edit the question to include the full router configurations from the show running-config command. What you show misses many configurations that we may need to see.
    – Ron Maupin
    Commented Oct 5, 2023 at 14:45

1 Answer 1

1

Your routers need to share an IP subnet. If you just invent some gateway addresses it won't work.

The dotted link between R2 and R3 is your shared subnet. Configure IP addresses from the same subnet on both sides (e.g. 10.0.1.2/31 and 10.0.1.3/31) and then add static routes for the networks behind R3 on R2 and vice versa. The gateway for each route is the opposite router's IP address.

1
  • @Zac67 Thanks you very much ! It worked very nice after a bit of reflexion. I created an account so I lost the question property haha... Thanks !!
    – akira
    Commented Oct 5, 2023 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.