2

I just configured a scenario of point to point frame relay. As shown in the figure, I mapped DLCI as shown below:

10:102  20:201
10:103  30:301

but I don't able to figure out how my ping from serial3/0.102 are reaching to serial3/0.301 when supposed to reach serial3/0.201 as because the mapping is from 102 to 201?

Ping from serial 3/0.102:

R1#ping 192.168.2.2 source serial 3/0.102
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 104/172/228 ms

Router configurations for Router 1:

interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0
 duplex half
!
interface Serial3/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial3/0.102 point-to-point
 ip address 192.168.1.1 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 102
!
interface Serial3/0.103 point-to-point
 ip address 192.168.2.1 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 103
!
router eigrp 1
 network 10.0.0.0
 network 192.168.1.0
 network 192.168.2.0
 auto-summary

Router configurations for Router 2:

interface FastEthernet0/0
 ip address 10.2.2.1 255.255.255.0
 duplex half 
!
interface Serial3/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial3/0.201 point-to-point
 ip address 192.168.1.2 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 201
!
router eigrp 1
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary

Router configurations for Router 3:

interface FastEthernet0/0
 ip address 10.3.3.1 255.255.255.0
 duplex half
!
interface Serial3/0.301 point-to-point
 ip address 192.168.2.2 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 301
!
router eigrp 1
 network 10.0.0.0
 network 192.168.2.0
 no auto-summary
!
interface Serial3/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0

Scenario: enter image description here

1 Answer 1

2

Why would the ping travel to R2 S3/0.201 from R1 S3/0.102? The source of the ping is just the source; it doesn't tell the ping which way to go or force the traffic out that interface.

It doesn't matter which interface you source from in R1 because the R1 routing table will direct it out the correct interface to get to the IP address. Sourcing the ping from the interface toward R2 doesn't matter since R1 knows it has to go out the interface to R3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.