Why does my SonicWall fail to allocate DHCP addresses to my virtual subnet?

I am trying to configure our VoIP phones. I have configured our sonicwall TZ 215 to have two networks on the LAN:

  • Interface X0: 192.168.1.x
  • Interface X0:V10 10.100.10.x

I have configured DHCPD on the sonicwall to allocate a static address,, to a phone with a specific mac address connecting over the X0 physical interface.

This works fine, if the static DHCP entry on the SonicWall allocates the address to the 192.X network. However, when I configure the static DHCP entry to allocate a 10.x address on the virtual interface subnet, the Sonic Wall does not provide a DHCP response to the phone.

Thank you for your help!!

Here are a few config images:

Lease Scopes enter image description here

Network Diagram: enter image description here

  • What is the brand/type of the unmanaged switch? Most likely it's stripping of the VLAN tags, so all your devices are connected to X0 rather than X0:V10.
    – RobinG
    Commented Feb 13, 2016 at 17:12
  • The unmanaged switch is a netgear 16 port FS 116. The DCHP request is sent by the phone which I can see on the phone's LAN. The sonicwall responds with a DHCP address of, from its pool of dynamic addresses. I see the DHCP response with the .130 address on the phone lan. I don't have a wireshark on the Router's lan, but I do see a request and response on the phone lan. As the DHCP flow is a lower 2 flow, I am not sure why a switch would strip of a VLAN tag from inside the DHCP option. What would you suggest?
    – jmurray
    Commented Feb 13, 2016 at 17:36
  • If I create a static dhcp scope in the 192. subnet (e.g., then the phone picks up a static 192.x address. However, when I disable the 192.x static dhcp scope and configure the static scope, the DHCP server only responds with the dynamic 192.x address (if the dynamic 192.x range is configured) or with nothing (if no dynamic range for 192.x is configured.
    – jmurray
    Commented Feb 13, 2016 at 17:43

1 Answer 1


You need to replace the switch with a managed switch that supports VLANs for this to work.

The Sonicwall X0 interface is configured as a trunk, with to VLANs: a "native" VLAN for untagged frames, and V10 for frames tagged with VLAN ID 10. Frames that arrive at the Sonicwall untagged come in at interface X0, and frames that are tagged with VLAN ID 10 come in at interface X0:V10.

The switch you have does not support VLANs. This means that it will send all traffic to the Sonicwall untagged. So regardless of what you configure on the IP Phone, traffic will arrive only on interface X0, and never on X0:V10.

In order for this to work, you would need to configure the switchports to the Sonicwall and to the IP Phones with an untagged "native" VLAN and a tagged VLAN 10. So you need to have a managed switch that supports VLANs instead of the unmanaged switch.

  • Thank you for your answer. I have ordered two L3 managed cisco switches. However, in the meantime, I have connected the phone directly to the sonicwall. The phone is a polycom vvx600 with VLAN support. When the phone tries to pull a DHCP address, it is having the same problem: The DHCPD does not provide it a 10.100.1.x dhcp response. Still testing. The DHCPD just does not want to serve a DHCP address on the subinterface.
    – jmurray
    Commented Feb 13, 2016 at 18:50
  • You should check VLAN configuration on the phone, should be set manually to VLAN ID 10 (see the Polycom FAQ). When your Cisco switches arrive, you can use automatic Voice VLAN discovery using CDP or LLDP.
    – RobinG
    Commented Feb 13, 2016 at 19:48
  • You are correct and it is now working. By adding VLAN ID 10 to the VLAN Menu on the phone, the phone was then able to pull the DHCP address THROUGH the unmanaged switch. Hence, the unmanaged switch is not stripping the VLAN id off. In the DHCP static scope entry, I configured a DHCP option to set the VLAN ID, which is working. But, ironically, and annoyingly, the phone cannot access that DHCP server option unless the VLAN ID is set manually on the phone! I see that once the managed switches arrive, I will then be able to set the config for the phone using CDP. Thank you!
    – jmurray
    Commented Feb 13, 2016 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.