1

I am having trouble configuring trunking on these switches. I am unsure how to configure different VLANs on different switches, each connected to one another. I tried to configure the 802.1Q trunk on these switches using the switchport encapsulation command. However, every time I issue this command, an error message occurs. I tried configuring the interface with the switchport mode trunk command. However, every time I issue the switchport allowed vlan command and then the VLAN numbers I want to enable, which are 1-3, I get an error message. Could you please provide an explanation as clearly as possible.

Switch1-vlan 1 is called Research and management. Switch2- vlan2 is called Sales and Marketing Switch3- vlan 3 is the server vlan

enter image description here

enter image description here

3
  • You will need to be a lot more specific than just showing us a picture and asking us to write your configurations. Please tell us what software versions you're using, what you've tried, what problems you ran into and how you've tried to solve them, and then we can help you.
    – Teun Vink
    Jan 8 '17 at 15:36
  • It appears you are using packet tracer -- which is great, but doesn't support all switch commands. For a thorough look at each of those commands and what they are doing, check out this article.
    – Eddie
    Jan 8 '17 at 21:03
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 15 '17 at 17:48
1

The allowed vlan command is not correct. Try using:

switchport trunk allowed vlan 1-3

As mentioned you'll want to ensure that all three switches have the vlans created and that all three are trunked on all links.

show interface trunk 

The above command will allow you to verify the trunking protocol and vlans in the trunk. as mentioned, some switches only support one protocol, and do not allow the encapsulation to be configured.

Also, it's a best practice to not use vlan 1 for anything.

4
  • Why is it bad practice to use VLAN 1? Jan 8 '17 at 22:51
  • VLAN 1 is traditionally used by Cisco for a bunch of specific on-box things. It's less an issue on NXOS boxes but avoiding it remains best practice on CatOS boxes. It still is used for some protocols (VTP being an example, but not the only one) and, as such, the general view is that a broadcast storm (or other problem) can have a broader set of effects than might occur on another VLAN.
    – rnxrx
    Jan 9 '17 at 2:44
  • Generally speaking, you wouldn't want to use VLAN 1 for a production traffic VLAN, since as mxrx mentioned, there are protocols that utilize it by default. Even in some cases if the native VLAN on a trunk is configured as a different VLAN. So to ensure traffic is isolated, just don't use it.
    – HostBits
    Jan 9 '17 at 3:32
  • There is nothing wrong with using VLAN1. Noone is running Cat OS. It is not best practice to avoid using VLAN 1. If I'm wrong, you should be able to show me the documentation or give a good reason. Jan 9 '17 at 4:07
1

You are missing the trunk keyword in your switchport allowed vlan 1-3 command:

switchport trunk allowed vlan 1-3

Also, many switches will now only do 802.1Q encapsulation, so the command to set the encapsulation is no longer needed or supported. It is only use on switches that can be set to different encapsulations.

0

First of all, you must configure all 3 VLANs on all Switches. After that you can deploy the trunking ports configuration:

Switch3: int fa0/5
Switchport mode trunk
Switchport trunk allowed vlan 1-3

Switch2: int fa0/4
Switchport mode trunk
Switchport trunk allowed vlan 1-3

Switch2: int fa0/1
Switchport mode trunk
Switchport trunk allowed vlan 1-3

Switch1: int fa0/2
Switchport mode trunk
Switchport trunk allowed vlan 1-3

I suppose that the Router R2 work like router on a stick ?

Switch1: int fa0/3
Switchport mode trunk
Switchport trunk allowed vlan 1-3

Cisco 2960 supports only IEEE 802.1Q trunking methods for sending VLAN traffic over Ethernet ports

1
  • Let me know if there's any other problem.
    – cost
    Jan 8 '17 at 16:55
-1

Issues with standing up trunking usually revolve around the ports shutting themselves down due to STP/loop protection. Start by administratively shutting down the ports you want to trunk. Then configure them, then administratively turn them hack up / no shut.

All you really have to do is configure a port-group 1 interface, then assign the individual port(s) to switchport mode trunk and trunk mode on (I believe/if I remember correctly), and lastly assign trunk group 1. Unshut, you're good.

5
  • 1
    I think you're talking about etherchannel or port-channeling. Question is about setting up a standard trunk.
    – HostBits
    Jan 8 '17 at 21:19
  • Yea, considering errdisable and shut/noshutting the port is a bad idea. Terrible answer. Jan 8 '17 at 22:49
  • well when the port is incorrectly configured, and the commands being used are wrong... yes. Plus if the ports were coming up and getting errdisabled then explain how to check for those issues in the logs or show commands, or even debug commands.
    – HostBits
    Jan 9 '17 at 3:30
  • Why waste time with show interface. just shut no shut it. done. Jan 9 '17 at 4:02
  • I don't know about you, but generally I like to know why something isn't working instead of just blindly fixing it. If you need to do an RCA, you'd be using debug logs and show commands.
    – HostBits
    Jan 9 '17 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.