1

Going through an exercise from the CCNA practice exam I encountered an example that required the configuration of link local addresses on all interfaces. On Router 1 all interfaces were set to FE80::1 as the link local. On Router 2 all interface were set to FE80::2 as the local link.

Is it necessary to set unique link local addresses on the routers interfaces? Could I have assigned FE80::1 to Router 2 interfaces?

!!!! Script for R1 !!!!
ena
conf t
ipv6 unicast-routing
interface g0/0
ip address 172.16.1.1 255.255.255.0
ipv6 address 2001:db8:1:1::1/64
ipv6 address fe80::1 link-local
no shutdown
interface g0/1
ip address 172.16.2.1 255.255.255.0
ipv6 address 2001:db8:1:2::1/64
ipv6 address fe80::1 link-local
no shutdown
interface s0/0/0
ip address 10.10.10.1 255.255.255.252
ipv6 address 2001:db8:f:f::1/64
ipv6 address fe80::1 link-local
no shutdown
end
copy running-config startup-config

!!!! Script for R2 !!!!
ena
conf t
ipv6 unicast-routing
interface g0/0
ip address 192.168.3.1 255.255.255.0
ipv6 address 2001:db8:2:3::1/64
ipv6 address fe80::2 link-local
no shutdown
interface g0/1
ip address 192.168.4.1 255.255.255.0
ipv6 address 2001:db8:2:4::1/64
ipv6 address fe80::2 link-local
no shutdown
interface s0/0/0
ip address 10.10.10.2 255.255.255.252
ipv6 address 2001:db8:f:f::2/64
ipv6 address fe80::2 link-local
no shutdown
end
copy running-config startup-config

2 Answers 2

3

No, the addresses still need to be unique on the links. Looking at your configuration S0/0/0 on R1 is connected to S0/0/0 on R2, so if you used the same address on both, they wouldn't be able to communicate using the link-local addresses. You could get away with using the same addresses on the gigabit interfaces, as they are not connected, but that is not good practice and could lead to issues in the future if they were connected. Best to use the same unique address per router.

0
1

Can you assign the same IP (v4) address to more than one node in the same LAN? No. It's no different for v6. The address has to be unique per broadcast domain. (even if v6 has no "broadcast" -- it uses the more specific multicast)

Link-local addresses have a scope of only that link. So, they don't have to be unique across multiple interfaces on the same device. They do have to be unique "on the wire". So how do you differentiate between fe80::1 on interface 1 vs interface 2? fe80::1%1 vs fe80::1%2 'tho that can be OS specific.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.