I am supposed to name 2 vlans, VLAN 10, and VLAN 20.

When I type

Switch(config-vlan)#Name VLAN 10
% Invalid input detected at '^' marker.

Could I get any help please.

  • 3
    You cannot use blank spaces, you need to use name VLAN_10 or name VLAN-10 etc.
    – user36472
    Oct 5 '18 at 18:04
  • What equipment are you working on? I just tried on a Catalyst 3560CX and that worked without a problem. Also the IOS version would be interesting to know.
    – user36472
    Oct 5 '18 at 18:12
  • 7
    Why on earth would you name VLAN 10 as "VLAN 10"? Normally, you want to name a VLAN for its use, such as naming VLAN 10 something like "Printers" or whatever purpose it serves. Some people name a VLAN for the floor it serves, or something else descriptive. You already know that VLAN 10 is VLAN 10, and you do not need to name it that way.
    – Ron Maupin
    Oct 5 '18 at 18:33
  • 4
    On some devices this works by using quotes name "VLAN 10" - but as Ron has noted, that name is useless.
    – Zac67
    Oct 5 '18 at 18:50
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Dec 25 '18 at 9:37

Use an underscore instead. ;)

Spaces aren't usually allowed in the names of interfaces.

Sometimes you can name with a space if you use Quotes "VLAN 10" but YMMV.


When configuring a VLAN's it's recommended by Cisco to use underscores instead of spaces.

Hence the correct configuration would be:

Switch(config-vlan)#name VLAN_10


Switch(config-vlan)#name VLAN_20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.