0

I have a 3750X that I am running some testing with. I have a VLAN interface that is using 10.10.10.254/21 as it's primary IP and 192.168.10.254/24 as it's secondary IP. See below:

interface Vlan10
 description Workstations
 ip address 10.10.10.254 255.255.248.0
 ip address 192.168.10.254 255.255.255.0 secondary
 no ip redirects

I also have a DHCP pool that is handing out IPs from the 10.10.10.x network, but not the 192.168.10.x network.

I go to plug in my laptop to a port on the switch and it automatically assigns an IP from the 10.10.10.x network. When I attempt to statically assign a random IP of 192.168.10.227/24, I am unable to ping the gateway in this case, 192.168.10.254.

Here are some factors:

-No other device is confirmed to be using 192.168.10.227.

-When I run show mac-address table filtering the interface that I am plugged into, I see the laptop plugged in, which is good.

-When I run sh arp filtering the MAC address again, no entry is showing for the 192.168 or 10. network.

CHS_3750X_STACK#show arp | i 57ee
CHS_3750X_STACK#

My question:

When I run a DHCP pool within the Cisco 3750X, am I unable to assign a static IP to my machine, even though it is within the subnet of what is stated on the interface VLAN?

  • Do you have IP routing enabled on the switch? – Ron Maupin Jul 25 '19 at 21:38
  • I do have ip routing enabled. – Craken Jul 25 '19 at 21:39
  • Please edit your question to include the full switch configuration. – Ron Maupin Jul 25 '19 at 21:41
  • 1
    What you do is obfuscate any public addresses and passwords. Private addresses like you have are fine. – Ron Maupin Jul 25 '19 at 21:45
  • 1
    You should answer the question and accept your answer (probably have to wait a couple of days to accept it), or you could simply delete the whole question. – Ron Maupin Jul 26 '19 at 19:00
2

This ended up being a configuration issue with the port I was plugged into with my laptop. The configuration on the interface was set to trunking rather than switchport access VLAN10. Once I set the interface to switchport mode access and switchport access vlan 10 then I was able to see the ARP entry along with being able to route outside the network.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.