0

I am trying to set up a Q in Q environment with EX2300(ELS). Unfortunately, I receive the error message down below when I enter commit check

[edit interfaces ge-0/0/0]
  'unit 0'
     VLAN-ID must be specified on tagged ethernet interfaces
error: configuration check-out failed

The Q in Q config which I followed right here: https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/qinq-tunneling-qfx-series-els.html

Also post my config of interfaces ge-0/0/0

flexible-vlan-tagging;
native-vlan-id 150;
encapsulation extended-vlan-bridge;
unit 0 {
    family ethernet-switching {
        storm-control default;
    }
}
unit 3251 {
    vlan-id 3251;
    input-vlan-map swap;
    output-vlan-map swap;
}

Do I miss something about QinQ or anything else?

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 15 '19 at 19:53
1

The issue is flexible-vlan-tagging is enabled on the port so each logical interface expects a VLAN ID. In your case unit 0 is created without a VLAN specified for that logical unit.

The logical interface on which untagged packets are to be received must be configured with the same native VLAN ID as that configured on the physical interface. To configure the logical interface, include the vlan-id statement (matching the native-vlan-id statement on the physical interface) at the [edit interfaces interface-name unit logical-unit-number] hierarchy level.

https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/interfaces-enabling-vlan-tagging.html

| improve this answer | |
  • Thanks for your reply. After I add a vlan-id which match with my native vlan I still get error message down below. [edit interfaces ge-0/0/0] 'unit 0' interface needs to be in a bridge-domain or evpn to support family bridge So I search about this message and I consider that I do not need the irb for CVLAN port cause ip address is unnecessary. Therefore, I tried to set "encapsulation vlan-bridge" for my unit 0 and it gets another error message. "Link encapsulation type is not valid for device type" – Lyj Nov 7 '19 at 2:12
  • Do you require having unit 0 defined at all for ge-0/0/0? – joshmatt Nov 7 '19 at 5:10
  • No, but unit 0 can not be delete or not to config. – Lyj Nov 7 '19 at 6:00
  • Can you paste the error you see when trying to delete unit 0? Unit 0 is definitely not required to be there unless something else in your configuration is referencing it. – Jordan Head Nov 12 '19 at 17:10
  • @JordanHead After I upgrade to version 18.1R3 I can delete the unit 0. Thanks for helping. However it shows another message 'unit 3251' interface needs to be in a bridge-domain or evpn to support family bridge – Lyj Nov 18 '19 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.