0

topology

i'm building this project for my final year project course. here,there is a cloud and all ports are bridged..and nearest router has taken IP from cloud over dhcp.

r1,r2,r3 are contact with their connected router but r4,r5,r6 can't contact with each other over the internet. what can i do now??

all configuration: -

                                  ROUTER 1: - 

interface FastEthernet0/0
 ip address dhcp
ip nat outside
no shutdown
interface FastEthernet1/0
 ip address 192.168.100.1 255.255.255.0
ip nat inside
no shutdown
ip nat inside source list 1 interface FastEthernet0/0 overload
access-list 1 permit any
ip domain-lookup
ip name-server 192.168.0.1 ( which is my wifi/cloud/internet ip address)

R1#ping google.com

Translating "google.com"...domain server (192.168.0.1) [OK]

Sending 5, 100-byte ICMP Echos to 172.217.31.206, timeout is 2 seconds: !!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/101/176 ms

                              ROUTER2: - 

interface FastEthernet0/0
 ip address dhcp
 ip nat outside
no shutdown
interface FastEthernet1/0
 ip address 192.168.101.1 255.255.255.0
 ip nat inside
no shutdown
ip nat inside source list 1 interface FastEthernet0/0 overload
access-list 1 permit any
ip domain-lookup
ip name-server 192.168.0.1 ( which is my wifi/cloud/internet ip address)

R2#ping google.com

Translating "google.com"...domain server (192.168.0.1) [OK]

Sending 5, 100-byte ICMP Echos to 172.217.31.206, timeout is 2 seconds: !!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/101/176 ms

                                   ROUTER 6: - 

interface FastEthernet1/0
 ip address 192.168.100.10 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 192.168.100.1
ip domain-lookup
ip name-server 192.168.0.1 ( which is my wifi/cloud/internet ip address)

R6#ping google.com

Translating "google.com"...domain server (192.168.0.1) [OK]

Sending 5, 100-byte ICMP Echos to 172.217.31.206, timeout is 2 seconds: !!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/101/176 ms

R6#ping 192.168.101.10 (router 5 ip address)

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.101.10, timeout is 2 seconds: ..... Success rate is 0 percent (0/5)

                                       ROUTER 5:- 

interface FastEthernet1/0
 ip address 192.168.101.10 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 192.168.101.1
ip domain-lookup
ip name-server 192.168.0.1 ( which is my wifi/cloud/internet ip address)

R5#ping google.com

Translating "google.com"...domain server (192.168.0.1) [OK]

Sending 5, 100-byte ICMP Echos to 172.217.31.206, timeout is 2 seconds: !!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 160/175/180 ms

R5#ping 192.168.100.10 (router 6 ip address)

Sending 5, 100-byte ICMP Echos to 192.168.100.10, timeout is 2 seconds: .....

Success rate is 0 percent (0/5)

router 3 configuration are same as router. 1,2 & router 4 configuration are same as router 5,6.

now which process may i follow to get ping among router 4 & 5 & 6 ???

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Commented Dec 17, 2020 at 14:53

1 Answer 1

2

You either need to set up static routes or use a routing protocol (OSPF, RIP, ...) to enable all routers to learn where remote subnets are located from each other.

PS (with the configs more readable): you seem to source NAT on R1/2/3 outside interfaces. That in turn requires you to create (VPN) tunnels between sites to route through for transparent addressing.

8
  • i already did it..but ,it did'not work.. Commented Jan 13, 2020 at 18:06
  • i create gre tunnel between r1 & r2 ... r1 can ping r2 lan ip(192.168.101.10 and r2 also can ping r1 lan ip(192.168.100.10) ...but ,still now ,r5 & r6 can't ping each other.. i can't create gre tunnel between r5 & r6..what can i do now?? Commented Jan 13, 2020 at 19:56
  • You still need routes pointing into the tunnel.
    – Zac67
    Commented Jan 13, 2020 at 20:25
  • thanks...it works...if i further face any problem about this,then i will knock you..please help me..because i have no one to provide me with guideline. Commented Jan 13, 2020 at 20:34
  • all is ok...but,still now r5 can't ping 192.168.100.1 (router 1 lan ip).. but ,can ping 192.168.100.10 ( router 6 ip address,which is connected to r1)..what's the reason? Commented Jan 13, 2020 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.