0

In this topology I have configured the devices in this way:

enter image description here

R1:

Building configuration...

Current configuration : 916 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX1017U862-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.1.1 255.255.255.252
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 ip address 10.1.1.5 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 172.16.3.0 255.255.255.0 10.1.1.2 
ip route 172.16.3.0 255.255.255.0 10.1.1.6 5
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R2:

Building configuration...

Current configuration : 714 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX101723IN-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.1.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.1.9 255.255.255.252
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 172.16.3.0 255.255.255.0 10.1.1.10 
ip route 192.168.1.0 255.255.255.0 10.1.1.1 
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R3:

Building configuration...

Current configuration : 715 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX1017BW6O-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.1.1.6 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.1.13 255.255.255.252
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 172.16.3.0 255.255.255.0 10.1.1.14 
ip route 192.168.1.0 255.255.255.0 10.1.1.5 
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R4:

Building configuration...

Current configuration : 889 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2811/K9 sn FTX1017OPU6-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.1.10 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.14 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 10.1.1.9 
ip route 192.168.1.0 255.255.255.0 10.1.1.13 5
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

When I ping from PC1 to PC2, the path to go from PC1 to PC2 is as follows:

enter image description here

But the way back, to go from PC2 to PC1 is as follows: (causing the packet to be discarded)

enter image description here

Question:

How can I make the return route, that is, from PC2 to PC1, be as follows, that is, although the path through the upper static route is active, it goes through the lower floating static route?

enter image description here

The packet tracer file is the following: https://www.mediafire.com/file/3dvgy683vestflg/Static_Routes.pkt/file

7
  • 2
    We do not want the Packet Tracer file, but we need the network device configurations. Please edit your question to include all the router configurations.
    – Ron Maupin
    Commented Aug 21, 2022 at 2:53
  • Ok. I'll edit my question in a moment. Commented Aug 21, 2022 at 4:22
  • UPDATE: I've just edited my question... Commented Aug 21, 2022 at 4:32
  • 2
    Again, please edit the question to include the router configurations. Use the show running-config command, copy the text, paste it into the question, and use the Pre-formatted-Text feature ({}) that is right next to the image feature you used.
    – Ron Maupin
    Commented Aug 21, 2022 at 4:55
  • 1
    Stateful packet inspection cannot work with asymmetric routing. Either remove the one or fix the other.
    – Zac67
    Commented Aug 21, 2022 at 7:05

1 Answer 1

2

R4 is sending it the wrong way to R2 SO you need to get router 4 to send it to R3 Theses are the two lines in R4 you need to fix

ip route 192.168.1.0 255.255.255.0 10.1.1.9 
ip route 192.168.1.0 255.255.255.0 10.1.1.13 5

Make the metric for R3 so it has a higher priority , lower metric - I tend to put metrics on all relevant routes so its obvious I thought about it - replace the lines above with

ip route 192.168.1.0 255.255.255.0 10.1.1.9 10
ip route 192.168.1.0 255.255.255.0 10.1.1.13 5
3
  • I understand your solution, but what I want is that when the upper link between R1 and R2 is restored, the packets go up through R2, in the graph that I show on purpose, I take the link between R1 and R2 out of service to analyze the static route. What I would like is that when the link between R1 and R2 goes down, the packets go through R3, but when the link between R1 and R2 goes up they go through R2. Commented Aug 22, 2022 at 13:08
  • That needs a routing protocol or assuming the routers support it SLA configuration, with SLA you can ping a device and then add a route if it succeeds
    – Ross
    Commented Aug 23, 2022 at 8:28
  • Also your question did not make it clear that you are changing the topology of the network "I take the link between R1 and R2 out of service ..." This is pretty important to understand what you are trying to solve - it maybe the little red marks are to indicate that - but you need to make it clear
    – Ross
    Commented Aug 24, 2022 at 5:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.