4

In the following topology my main purpose is to:

1)PC11 ping Router(R)

2)PC11 ping PC13

ESW10:

In gig0/3 has the no switchport command and a given IP address.

In gig0/2 it has the switchport access VLAN 10 command.

In gig0/0 it has a given IP and the no switchport command.

In gi0/1 has switchport access VLAN 10 command.

PC11 can ping PC9

R can ping ESW10

ESW10 can ping ESW11.

enter image description here

So my question is what do I need to add and where for PC11 and PC9 to ping R and eventually PC13

Device Configs:

ROUTER

interface GigabitEthernet0/0 
ip address 192.168.2.1 255.255.255.0 
duplex full 
interface GigabitEtherneto/1
ip address 192.168.3.1 255.255.255.0 
duplex auto 

ESW10

interface GigabitEthernet0/0 
no switchport 
ip address 192.168.1.1 255.255.255.0 
negotiation auto
interface GigabitEthernet0/1 
switchport access vlan 10 
switchport mode access 
negotiation auto
interface GigabitEthernet0/2 
switchport access vlan 10 
switchport mode access 
negotiation auto
interface GigabitEthernet0/3 
no switchport 
ip address 192.168.2.2 255.255.255.0 
negotiation auto

ESW11

interface GigabitEthernet0/0 
no switchport 
ip address 192.168.1.2 255.255.255.0 
negotiation auto
interface GigabitEthernet0/1 
switchport access vlan 10 
switchport mode access 
negotiation auto
interface GigabitEtherneto/2 
switchport access vlan 10 
switchport mode access 
negotiation auto
1
  • 2
    Please add the full configurations to your question (using the { } editor function). We cannot guess what you did wrong.
    – Zac67
    Mar 28 at 20:54

1 Answer 1

4

You did not include the full configurations as asked, but there seem to be a few problems:

  • I do not see that you have enable routing on EWS10 with the ip routing command.
  • I do not see that you have added a route to 10.168.3.0/24 on ESW
  • I do not see that you have added a route to 192.168.1.0/24 on R1.

Routers need to know how to reach networks other than their directly attached networks, either with static routes or with a routing protocol.

4
  • I put only this config because it was what needed for the answer and the only config the devices had. What you said helped a lot and one last thing that doesnt work is that PC11 cant ping ESW10. What do i need to do about that?
    – ECHO
    Mar 28 at 21:56
  • 1
    If you had put in the entire configuration, then we could see right away wat the problem is. What you thought was relevant was only part of what was actually relevant. Please, when someone asks you for the full configuration, please provide it. If you really knew everything that is relevant, you would not be asking fo help.
    – Ron Maupin
    Mar 28 at 22:32
  • 1
    @ECHO, the switch address should be on an SVI for that VLAN Normally, you connect switch-to-switch with a trunk interface, and each switch gets an address on an SVI, which is a virtual interface that never goes down in the case of an interface cable being removed. The design you have is something that would not be used. You would also configure an IP default gateway on a layer-2 switch (never on a device with routing enabled) like ESW 11..
    – Ron Maupin
    Mar 28 at 22:45
  • Thanks a lot . The tips above where very helpful.
    – ECHO
    Mar 28 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.